* indicates required

RadLab Support

Choose a topic below to learn more!

Have a question or suggestion? Open a Support Ticket and tell us what’s on your mind.

New to RadLab?

Check out our Quickstart Guide and you’ll be up and running in minutes.

RadLab | Instructions

All of the random bits of information that don’t quite fit anywhere else can be found here. In random-ish order.

  • RadLab is NOT an action. It actually has nothing to do with actions, and can’t run our actions or anyone else’s. In order to get those nifty, instant previews, we had to build something entirely different, from the ground up. It’s a Photoshop Filter Plugin, which means that it does all its own pixel math. Over the long haul, this gives us MUCH more flexibility in what we can accomplish.
  • RadLab is currently only compatible with RGB images. We might support grayscale in the future by automatically converting an image back and forth between gray and RGB, but we have no planned support for bitmap or CMYK or any other color modes. RadLab was designed for photography first and foremost, and a lot of its processing relies on having RGB images.
All of the Stylets that you apply to an image, along with any Stylet parameter tweaks, are the Recipe for that photo. The Recipe for the current photo is shown in the Recipe panel on the right. Any time you add a Stylet, it appears in the Recipe panel, and when you preview a Stylet or Recipe by hovering your mouse over it in the Library, the Recipe panel changes to show what the current image’s Recipe would be if you clicked.

Recipes are applied from top to bottom, just like a list of things to do. The Basic Adjustments are also part of the current recipe, though they have their own special panel. The Basic Adjustments to Brightness, Contrast, and Warmth are applied before any Stylets.

Modifying The Current Recipe

  • Add to the current recipe by clicking on a Stylet in the Library.
  • Delete a Stylet in the current Recipe by clicking the trashcan icon next to that Stylet in the Recipe panel.
  • You can show additional controls for a Stylet (if a Stylet has more than one) by clicking the triangle underneath the Stylet name in the Recipe Panel.
  • Change the parameters of the Stylets in the current Recipe with the sliders.
  • You can enable or disable a Stylet from a Recipe without removing it by clicking the checkbox beside the Stylet name.

Saving Recipes

If you like the current recipe, and would like to use it again, then save it! Click the Save button at the bottom of the Recipe panel, type a name for your Recipe, and click OK. Your saved Recipe will now be available in your Library for easy recall.

Importing Recipes

  • Download and extract your recipes to your computer (if necessary).
  • Open RadLab.
  • Click the “Import” button at the top of the RadLab Library.
  • Navigate to where you saved your recipes on your computer and select the recipes you’d like to import.

Check out this video that explains the process in one minute.

Using The Keyboard

You can use your keyboard to navigate the Recipe Panel and change settings. Click on a Stylet name to select it. The currently active Stylet will have its name italicized. Use the up and down arrow keys to select different parameters, and the right and left arrow keys to move the sliders. Holding the CMD key (CTRL on Windows) while using the left / right arrows will make sliders move in increments of 1.

You can also press Enter to type a value for a slider directly into the box. Pressing enter again confirms the new value.

The Library in RadLab is the most important part of the program. Here, you’ll see instant previews of your Stylet and Recipe collection, as they’d look if you applied them to the current image. Every time you add a Stylet, the Stylet thumbnails update to show how they would change the current image. Using Stylets and Recipes can be as simple as just scrolling until you see something you like.

Stylets

Stylets are single modules of processing magic, that you can combine together to create the perfect look for your images. Each Stylet behaves a little differently, and every Stylet has at least one parameter you can change to alter its behavior. You can add the same Stylet to a photo multiple times, if you’d like.

Your Stylet collection is displayed in thumbnail form, organized by category, in the Library window. Click the Stylets button at the top of the Library to show them. You can collapse and expand the categories in the Library by clicking on the small triangle beside the category name. Hovering over a thumbnail with your mouse will change the Preview and Recipe panels to a preview of how that Stylet would alter the photo. Use this to get a closer look at exactly how a Stylet will look before adding it. Click the thumbnail to add a Stylet to the current Recipe.

Recipes

A Recipe is a collection of Stylets and their parameters. Applying a Recipe to an image will replace the current recipe. To access your Recipes, click the Recipes button at the top of the panel. Recipes are user-created, so you’ll have to create some before this area has a lot to look at. Using Recipes is exactly the same as using Stylets, with the exception that applying a Recipe will replace, rather than add to, the current image’s Stylets. Browse your Recipes by scrolling through the Library window. Hover over a Recipe to get a preview, and click to apply. You can delete a Recipe by clicking the trashcan icon beside it.

The Library also includes a History of your recent recipes. Your Recipe History is shown at the bottom of the Recipes listing in the Library. You can apply previous recipes by simply clicking on them.

Here’s a quick tour of the RadLab interface to get you started:

The Preview Area

What your image looks like with the current Recipe applied. You can choose to show the Before image, the After image, or to compare Before and After versions with a split or side-by-side view. You can also display the image at 100% (1:1 actual pixels) magnification, or to fit the image into the Preview Panel.

The Library

This is where you pick what you want to do with your photo. The library has two modes: Stylets and Recipes. Stylets are added one by one to the processing of your image, while Recipes are a collection of one or many Stylets. You can toggle between Recipes and Stylets at the top of the Library. In the Recipe view you may import and export Recipes to share with other RadLab users. You may also search your library and change the thumbnail size with controls below the window. For more on the Library, see the section on the RadLab Library.

Panel Controls

Here you can toggle the visibility of different parts of the RadLab interface and get help from our Support section.

Basic Adjustments

Use these quick, simple controls to adjust brightness, contrast, and warmth. Their settings are considered part of the Recipe, and will be included in saved Recipes.

Recipe

The Recipe applied to a photo is the collection of Stylets you’ve chosen to add, along with their associated parameters. The list of Stylets and their parameters is shown in the Recipe Panel. Stylets are applied from top to bottom, and you can adjust and tweak the Recipe in this panel. For more, see the section on RadLab Recipes

Favorites

You can add Recipes and/or Stylets to the Favorites panel for easy, one-click access. Click the heart icon in the Library, or drag the thumbnail from the Library to the Favorites panel to add them to your favorites. Click to add Stylets or apply Recipes to the current photo. Click the trashcan icon to remove them from your Favorites.

Histogram

Choose between either a per-channel or composite (gray) histogram for the current image.

Finish / Cancel

Choose to either Finish with this recipe and return the image to Photoshop, or to Cancel and return with no changes.

RadLab is a Photoshop Plugin, NOT an action. Therefore you have a few options for opening RadLab:

  1. Head to Filter -> Totally Rad -> RadLab from the Photoshop menu.
  2. If you are using Photoshop CS4 or CS5, you can (and should!) use the RadLab Panel to launch RadLab and configure your layers. (see below for instructions)
  3. Record an action that uses RadLab, and play the action. See This Tutorial to learn how.
  4. Use the Last Filter option (CMD-F on a Mac, CTRL-F on a PC) to apply the last recipe you used to the current layer.

Using the RadLab Panel

The RadLab Panel is installed automatically. To make it visible, select File -> Automate -> RadLab Panel from the Photoshop menu. The RadLab Panel will appear as a floating palette that you can collapse into a sing-button mini-panel. Try moving the mini-panel to just under your Photoshop tools palette (that’s a very convenient place for it). You can select from several layering options, and launch RadLab with a single click from this panel. This is the only way to start with a blank recipe, and is the way we suggest you access RadLab.

To install RadLab:

  1. Download the installer program for your platform. Login at www.gettotallyrad.com/store, and select Completed Orders. Select your RadLab purchase, and download either the Mac or the Windows version.
  2. Save the download to a convenient location on your computer (your Desktop, perhaps?)
  3. Double-click to open the installer you just downloaded.
  4. Follow the instructions on your screen until you are prompted for your email (username) and password from the Totally Rad Store. Enter them when requested, and the installer will download the remaining files.
  5. After installation, restart Photoshop.

If you have any issues with installation, don’t hesitate to Contact Us, and we’ll help!

RadLab | Tutorials

One of the coolest parts of RadLab is the ability to save, export, and share recipes. You can send your RadLab recipes to other users, and import recipes you’ve downloaded to use yourself. It’s super-easy to do, and here’s how it works.


Step 1

Work Some Magic

RadLab ScreenshotOpen up RadLab and work some post-processing magic. Add, remove, and tweak Stylets until you have a recipe you’re proud of.

Step 2

Save It

Before clicking Finish, click the Save button at the bottom of your Recipe panel. Give your recipe a name (something original, colorful, inspiring, and yet descriptive and functional… no pressure!)

If you forget to hit Save before exiting RadLab, you can always open RadLab again, and choose the last item in your Recipe History. This will load your recipe up, which you can then save permanently with the Save button (your history only remembers the most recent recipes).


Step 3

Export It

Click over to the recipe tab in your library, and find your fancy new recipe. Hover your mouse over the recipe thumbnail, and you’ll see some icons appear below it. Click the Export icon (with the arrow pointing down).

Choose a location to save your recipe to on your computer.


Step 4

Share the Magic

Your recipe is now wrapped up into a single file, with a .rls extension. Send it to a friend, or share it with the world.

You can use Photoshop to run a batch of images through RadLab. The workflow is very similar to batch processing with actions. Here’s how you do it.


Step 1

Create An Action

Photoshop’s Batch and Image Processor commands can only run actions, so the first thing you’ll need is a Photoshop Action.

Head over to your actions palette. Actions need to live in an Action Set, so unless you already have one set up for your own actions, start by clicking the folder icon to create a new Action Set. Then click the New Action button. Give it a nifty name. When you click the Record button to create your action, Photoshop will start paying attention to everything you do, and will record it in an action.


Step 2

Run RadLab With Your Recipe

Head to the Filter menu (NOT the RadLab Launcher Panel). Re-work your photo to your liking. Whatever adjustments you apply to this image will be encapsulated in your action, allowing you to apply your recipe to bunches and bunches of images. You can load a saved recipe or make one up as you go. When you hit “Finish”, the recipe you’ve just applied to this photo will be baked into the action, ready to go.

Step 3

Finish Recording Your Action

When you’re done in RadLab, click the Stop Recording button in the Actions Palette (otherwise, your action will keep recording everything you do, and will be a giant mess).

Step 4

Queue Up A Batch

Finally, head to File -> Scripts -> Image Processor. Choose the folder of images you’d like to process, select where you want to save them, and choose a file format for the output. Near the bottom, you can select an action to run on each photo. Choose the action you just created.

Hit Run, and RadLab’s magic will be applied en masse to the entire folder of images. Congrats! You’re now a certified Level 2 Workflow Ninja!

If you prefer one-click access to your favorite recipes, need to do batch processing, or just plain like the Photoshop actions palette, you can use RadLab as part of a Photoshop Action.

RadLab is technically just a Photoshop filter, just like anything else in the Filter menu (though a very fancy one). This means that if you record an action, then run RadLab, it will be recorded in the action just as if you were doing anything else in Photoshop.

To learn how to use Photoshop Actions with RadLab, check out this brief video

WHY USE ACTIONS WITH RADLAB?

There are a couple of distinct advantages of using RadLab’s Stylets in the place of our Photoshop Actions. For instance, if you wanted to run Old Skool on a photo:

  1. RadLab is MUCH faster than the action equivalent
  2. RadLab will give you the same results regardless of what size photo you want
  3. RadLab lets you tweak and customize the behavior of a Stylet, unlike actions, which are difficult and error-prone to customize
Since RadLab is a Photoshop Filter, it’s possible to take advantage of Photoshop’s Smart Filters feature to allow true non-destructive editing of your images. Smart Filters and Smart Objects allow you to change the RadLab recipe you’ve applied, even after you’ve exited RadLab and performed additional work in Photoshop.

Without the RadLab Panel

  1. Copy a merged version of your document to a new layer. The shortcut key Cmd-Shift-Option-E will do this for you (Ctrl-Shift-Alt-E on Windows).
  2. From the Photoshop menu, select Layer -> Smart Objects -> Convert To Smart Object
  3. Run RadLab via Filter -> Totally Rad -> RadLab

RadLab also makes using Smart Objects a one-click operation for Photoshop CS4 and CS5 users. Here’s how you do it:

Via the RadLab Panel

  1. Make sure your RadLab Panel is visible (CS4 and CS5 users only)
  2. Select “New Smart Object” from the drop-down menu
  3. Click “Open RadLab”

That’s it. A new Smart Object will be created with your recipe, making it easy to later edit or mask the result.

Editing Your Recipe Later

When you apply a filter, like RadLab, to a Smart Object, you get a Smart Filter entry below that Smart Object in the layers palette. You can double-click on the RadLab entry in the list of Smart Filters to bring up the RadLab interface and make changes to your recipe. When you click Finish, your image in Photoshop will be updated with the new Recipe from RadLab.

Changelog

v1.2.24 (7/9/12)

  • Standalone RadLab now reads and uses embedded ICC profiles in JPEG and TIFF files, yielding correct color behavior for Adobe RGB, ProPhoto RGB, etc when used as a Lightroom external editor
  • Fix a few UI nits

v1.2.22 (6/25/12)

  • Substantially improves (and possibly fixes) a bug that would freeze RadLab for a handful of users on Win7
  • Fixes a rare issue where certain combinations of Stylets would oversaturate and posterize
  • Copies JPEG or TIFF metadata when using RadLab as an external editor in Lightroom. Your star ratings and keywords should be safe, now!
  • Updated gradient algorithm for EZ-Burn, Old Skool, Vignette & Blur, resulting in MUCH less visible banding

v1.2.21 (6/21/12)

  • Fix for Windows hang on exit bug.
  • Fix for TIFF handling in standalone / LR RadLab on Windows.

v1.2.20 (6/14/12)

  • Preserve ratings, timestamp, and other EXIF data in output from standalone/LR RadLab

v1.2.19 (6/13/12)

  • Fix for bug in standalone/LR RadLab where final file was not written to disk

v1.2.18 (6/12/12)

  • Automatically install RadLab as an external editor in Lightroom (beta)
  • Fix for very slow plugin startup on Windows (10 seconds) introduced in 1.2.15

v1.2.16 (6/5/12)

  • Preliminary support for RadLab as an external editor in Lightroom and iPhoto (must manually configure in LR)
  • Preliminary support for user-generated stylets (still undocumented)

v1.2.13 (5/29/12)

  • Fix for occasional crash on 16-bit images introduced in 1.2.9

v1.2.12 (5/22/12)

  • Further improvements to panel startup stability

v1.2.9 (5/15/12)

  • Even more robust panel startup behavior
  • Fixed progressive darkening of images by <= 1 shade due to rounding errors
  • Licensed To now appears in About box
  • Minor speedups for some stylets and recipes

v1.2.8 (Windows Only) (4/4/12)

  • Fixed launcher panel crash on Windows

v1.2.5, 1.2.7 (3/15/12)

  • Fixed launcher panel crash on OSX 10.7

v1.2.3 (2/29/12)

  • Updated installer with better behavior

v1.2.2 (1/30/12)

  • Fix for crashes with 16-bit images under Windows

v1.2 (1/10/12)

  • Fix for crashes with 16-bit images and Boutwell Magic Glasses II Stylet
  • Full 16-bit support (no longer “beta”)

v1.1.8 (12/20/11)

  • Fix for issue where customers who used different email addresses for the demo and the full version of RadLab received “expired demo” messages

v1.1.7 (12/13/11)

  • 16-bit support (beta)
  • Fix for R6025 “pure virtual function call” crash in Windows

v1.1.2 (11/1/2011)

  • Prevents installation while Photoshop is running (because this breaks things)
  • Bugfix for random black tiles in preview images
  • Bugfix for crash when many recipes are installed
  • When RadLab panel is disabled because of image mode constraints, panel now provides some sensible feedback as to why
  • Installer now works with Photoshop Elements 10
  • Performance improved at plugin startup

v1.1.0

  • Completely redesigned launcher panel, providing increased stability, and increased compatibility (CS3 and Photoshop Elements users can now use our panel)
  • Improved stability and speed, especially with batch processing
  • Better performance and stability with memory-constrained systems (plays nicer with Photoshop’s memory allocation scheme)
  • Improved recipe management

v1.0.12 (8/24/2011)

  • Fix for crash when clicking to the Recipes tab in some circumstances
  • Thumbnails now display correctly when larger than the preview
  • Better installer support for internationalized plug-in folder names
  • Recipe sliders no longer intercept mouse wheel events

v1.0.11

  • Improved memory handling – fixes “out-of-memory” errors in most cases
  • Fixed installer bug that prevented installation where only Photoshop Elements was installed

v1.0.9

  • Various fixes to improve the reliability of the installer

v1.0.6 (8/2/2011)

  • Initial public release